fbpx

VMware Security Advisories – Noviembre 2020

VMware Security Advisories – Noviembre 2020

Fecha de publicación: Diciembre 10, 2020.

VMSA-2020-0025

2020-11-18

1. Productos afectados

VMware SD-WAN Orchestrator (SD-WAN Orchestrator)

2. Introducción

Se informaron de forma privada a VMware varias vulnerabilidades en SD-WAN Orchestrator. Hay parches y soluciones disponibles para remediar o solucionar esta vulnerabilidad en los productos VMware afectados. Los orquestadores SD-WAN alojados en VMware se han parcheado para estos problemas.

3a. Vulnerabilidad de inyección de SQL debido a una validación de entrada incorrecta (CVE-2020-3984)

Descripción

SD-WAN Orchestrator no aplica la validación de entrada correcta que permite la inyección SQL. VMware ha evaluado que la gravedad de este problema se encuentra en el rango de gravedad Importante con una puntuación base máxima de CVSSv3 de 7.1.

Vectores de ataque conocidos

Un usuario de SD-WAN Orchestrator autenticado puede explotar una llamada API vulnerable mediante consultas SQL especialmente diseñadas que pueden conducir a un acceso no autorizado a los datos.

Resolución

Para remediar CVE-2020-3984, aplique los parches enumerados en la columna ‘Versión fija’ de la ‘Matriz de respuesta’ a continuación.

Matriz de respuesta

ProductoVersiónQue se ejecuta enIdentificador CVECVSSv3GravedadVersión fijaSoluciones alternativasDocumentación adicional
Orquestador SD-WAN4.xAlgunaCVE-2020-39847.1Importante No afectadoN / AN / A
Orquestador SD-WAN3.xN / ACVE-2020-39847.1Importante 3.3.2 compilación p3 3.3.2-GA-20201103, 3.4.4 compilación R344-20201103-GANingunaNinguna

3b. Ejecución de archivos transversales de directorio (CVE-2020-4000)

Descripción

SD-WAN Orchestrator permite ejecutar archivos a través del recorrido de directorio. VMware ha evaluado que la gravedad de este problema se encuentra en el rango de gravedad moderada con una puntuación base máxima de CVSSv3 de 6,5.

Vectores de ataque conocidos

Un usuario de SD-WAN Orchestrator autenticado puede atravesar directorios que pueden conducir a la ejecución de código de archivos.

Resolución

Para remediar CVE-2020-4000, aplique los parches enumerados en la columna ‘Versión fija’ de la ‘Matriz de respuesta’ a continuación.

Matriz de respuesta

ProductoVersiónQue se ejecuta enIdentificador CVECVSSv3GravedadVersión fijaSoluciones alternativasDocumentación adicional
Orquestador SD-WAN4.xLinuxCVE-2020-40006.5Moderar 4.0.1NingunaNinguna
Orquestador SD-WAN3.xLinuxCVE-2020-40006.5Moderar 3.3.2 compilación p3 3.3.2-GA-20201103, 3.4.4 compilación R344-20201103-GANingunaNinguna

3.c Contraseñas predeterminadas Pass-the-Hash Attack (CVE-2020-4001

Descripción

SD-WAN Orchestrator tiene contraseñas predeterminadas que permiten un ataque Pass-the-Hash. VMware ha evaluado que la gravedad de este problema se encuentra en el rango de gravedad moderada .

Vectores de ataque conocidos:

SD-WAN Orchestrator se envía con contraseñas predeterminadas para cuentas predefinidas que pueden conducir a un ataque Pass-the-Hash.
Nota: La misma sal se utiliza junto con la contraseña predeterminada de cuentas predefinidas en sistemas recién instalados que permiten Pass-the-Hash-Attacks. Un atacante podría acceder a ese mismo sistema utilizando la contraseña predeterminada para la cuenta predefinida.

Resolución:

Para solucionar CVE-2020-4001, cambie las contraseñas predeterminadas de las cuentas preconfiguradas en SD-WAN Orchestrator antes del uso en producción.

Matriz de respuesta:

ProductoVersiónQue se ejecuta enIdentificador CVECVSSv3GravedadVersión fijaSoluciones alternativasDocumentación adicional
Orquestador SD-WAN4.xLinuxCVE-2020-4001n / AModerar Ver sección ResoluciónNingunaNinguna
Orquestador SD-WAN3.xLinuxCVE-2020-4001N / AModerar Ver sección ResoluciónNingunaNinguna

3.d escalamiento de privilegios de punto final de API (CVE-2020-3985)

Descripción:

SD-WAN Orchestrator permite un acceso para establecer niveles de autorización arbitrarios que conducen a un problema de escalada de privilegios. VMware ha evaluado que la gravedad de este problema se encuentra en el rango de gravedad Importante con una puntuación base máxima de CVSSv3 de 7,5.

Vectores de ataque conocidos:

Un usuario autenticado de SD-WAN Orchestrator puede aprovechar la debilidad de una aplicación y llamar a una API vulnerable para elevar sus privilegios.

Resolución:

Para remediar CVE-2020-3985, aplique los parches enumerados en la columna ‘Versión fija’ de la ‘Matriz de resolución’ que se encuentra a continuación.

Matriz de respuesta:

ProductoVersiónQue se ejecuta enIdentificador CVECVSSv3GravedadVersión fijaSoluciones alternativasDocumentación adicional
Orquestador SD-WAN4.xLinuxCVE-2020-39857.5Importante No afectado.N / AN / A
Orquestador SD-WAN3.xLinuxCVE-2020-39857.5Importante 3.3.2 compilación p3 3.3.2-GA-20201103, 3.4.4 compilación R344-20201103-GANingunaNinguna

3.e Manejo inseguro de los parámetros del sistema (CVE-2020-4002)

Descripción:

SD-WAN Orchestrator maneja los parámetros del sistema de forma insegura. VMware ha evaluado que la gravedad de este problema se encuentra en el rango de gravedad Importante  con una puntuación base máxima de CVSSv3 de 7,2.

Vectores de ataque conocidos:

Un usuario de SD-WAN Orchestrator autenticado con altos privilegios puede ejecutar código arbitrario en el sistema operativo subyacente.

Resolución:

Para remediar CVE-2020-4002, aplique los parches enumerados en la columna ‘Versión fija’ de la ‘Matriz de resolución’ que se encuentra a continuación.

Matriz de respuesta:

Documentación adicionalVersiónQue se ejecuta enIdentificador CVECVSSv3GravedadVersión fijaSoluciones alternativasDocumentación adicional
Orquestador SD-WAN4.xLinuxCVE-2020-40027.2Importante 4.0.1NingunaNinguna
Orquestador SD-WAN3.xLinuxCVE-2020-40027.2Importante 3.3.2 compilación p3 3.3.2-GA-20201103, 3.4.4 compilación R344-20201103-GA

3.f Divulgación de información de inyección SQL (CVE-2020-4003)

Descripción:

Se descubrió que SD-WAN Orchestrator es vulnerable a los ataques de inyección de SQL, lo que permite la posible divulgación de información. VMware ha evaluado que la gravedad de este problema se encuentra en el rango de gravedad moderada  con una puntuación base máxima de CVSSv3 de 6,3.

Vectores de ataque conocidos:

Un usuario autenticado de SD-WAN Orchestrator puede inyectar código en consultas SQL que pueden conducir a la divulgación de información.

Resolución:

Para remediar CVE-2020-4003, aplique los parches enumerados en la columna ‘Versión fija’ de la ‘Matriz de resolución’ que se encuentra a continuación.

Matriz de respuesta:

ProductoVersiónQue se ejecuta enIdentificador CVECVSSv3GravedadVersión fijaSoluciones alternativasDocumentación adicional
Orquestador SD-WAN4.xLinuxCVE-2020-40036.3Moderar 4.0.1NingunaNinguna
Orquestador SD-WAN3.xLinuxCVE-2020-40036.3Moderar 3.3.2 compilación p3 3.3.2-GA-20201103, 3.4.4 compilación R344-20201103-GANingunaNinguna

4. Referencias

Versión (s) fija (s) y notas de la versión:

4.0.1
https://www.vmware.com/go/download-sd-wan
https://docs.vmware.com/en/VMware-SD-WAN-by-VeloCloud/4.0.1/rn/VMware- SD-WAN-401-Release-Notes.html
3.4.4
https://www.vmware.com/go/download-sd-wan
3.3.2 P3
https://www.vmware.com/go/download-sd -pálido

Enlaces del diccionario Mitre CVE:

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-3984https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-3985https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-4000https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-4001https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-4002https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-4003

PRIMERA Calculadora CVSSv3:

CVE-2020-3984 – https://www.first.org/cvss/calculator/3.0#CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/ Yo: L / A: N

CVE-2020-4000 -https: //www.first.org/cvss/calculator/3.0#CVSS: 3.0 / AV: N / AC: H / PR: N / UI: N / S: U / C: L / I: H / A: N
CVE-2020-3985 – https://www.first.org/cvss/calculator/3.0#CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S : U / C: H / I: H / A: H

CVE-2020-4002 – https://www.first.org/cvss/calculator/3.1#CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/ I: H / A: H
CVE-2020-4003 – https://www.first.org/cvss/calculator/3.1#CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S : U / C: L / I: L / A: L

VMSA-2020-0026.1

2020-11-19

1. Productos afectados

  • VMware ESXi
  • VMware Workstation Pro / Player (estación de trabajo)
  • VMware Fusion Pro / Fusion (Fusion)
  • Fundación VMware Cloud

2. Introducción

Se informaron de forma privada a VMware varias vulnerabilidades en VMware ESXi, Workstation y Fusion. Hay actualizaciones disponibles para remediar estas vulnerabilidades en los productos VMware afectados.

3a. Vulnerabilidad de uso después de la ausencia en el controlador USB XHCI (CVE-2020-4004)

Descripción

VMware ESXi, Workstation y Fusion contienen una vulnerabilidad de uso después de la ausencia en el controlador USB XHCI. VMware ha evaluado que la gravedad de este problema se encuentra en el rango de gravedad crítica con una puntuación base máxima de CVSSv3 de 9,3.

Vectores de ataque conocidos

Un actor malintencionado con privilegios administrativos locales en una máquina virtual puede aprovechar este problema para ejecutar código como el proceso VMX de la máquina virtual que se ejecuta en el host.

Resolución

Para remediar CVE-2020-4004, aplique los parches enumerados en la columna ‘Versión fija’ de la ‘Matriz de respuesta’ que se encuentra a continuación.

Soluciones alternativas

Las soluciones provisionales para CVE-2020-4004 se enumeran en la columna ‘Soluciones provisionales’ de la ‘Matriz de respuesta’ a continuación.

Matriz de respuesta:

ProductoVersiónQue se ejecuta enIdentificador CVECVSSv3GravedadVersión fijaSoluciones alternativasDocumentación adicional
ESXi7.0AlgunaCVE-2020-40049.3Crítico ESXi70U1b-17168206Retire el controlador XHCI (USB 3.x)Ninguna
ESXi6,7AlgunaCVE-2020-40049.3Crítico ESXi670-202011101-SGRetire el controlador XHCI (USB 3.x)Ninguna
ESXi6.5AlgunaCVE-2020-40049.3Crítico ESXi650-202011301-SGRetire el controlador XHCI (USB 3.x)Ninguna
Fusión12.xOS XCVE-2020-4004N / AN / AInafectadoN / AN / A
Fusión11.xOS XCVE-2020-40049.3Crítico 11.5.7Retire el controlador XHCI (USB 3.x)Ninguna
Puesto de trabajo16.xAlgunaCVE-2020-4004N / AN / AInafectadoN / AN / A
Puesto de trabajo15.xAlgunaCVE-2020-40049.3Crítico 15.5.7Retire el controlador XHCI (USB 3.x)Ninguna
VMware Cloud Foundation (ESXi)4.xAlgunaCVE-2020-40049.3Crítico 4.1.0.1Retire el controlador XHCI (USB 3.x)Ninguna.
VMware Cloud Foundation (ESXi)3.xAlgunaCVE-2020-40049.3Crítico 3.10.1.2Retire el controlador XHCI (USB 3.x)Ninguna

3b. Vulnerabilidad de elevación de privilegios de VMX (CVE-2020-4005)

Descripción

VMware ESXi contiene una vulnerabilidad de escalamiento de privilegios que existe en la forma en que se administran determinadas llamadas al sistema. VMware ha evaluado que la gravedad de este problema se encuentra en el  rango de gravedad Importante  con una puntuación base máxima de CVSSv3 de 8,8.

Vectores de ataque conocidos

Un actor malintencionado con privilegios dentro del proceso VMX únicamente, puede escalar sus privilegios en el sistema afectado. La explotación exitosa de este problema solo es posible cuando está encadenado con otra vulnerabilidad (por ejemplo, CVE-2020-4004).

Resolución

Para remediar CVE-2020-4005, aplique los parches enumerados en la columna ‘Versión fija’ de la ‘Matriz de respuesta’ que se encuentra a continuación.

Matriz de respuesta:

ProductoVersiónQue se ejecuta enIdentificador CVECVSSv3GravedadVersión fijaSoluciones alternativasDocumentación adicional
ESXi7.0AlgunaCVE-2020-40058.8Importante ESXi70U1b-17168206NingunaNinguna
ESXi6,7AlgunaCVE-2020-40058.8Importante ESXi670-202011101-SGNingunaNinguna
ESXi6.5AlgunaCVE-2020-40058.8Importante ESXi650-202011301-SGNingunaNinguna
VMware Cloud Foundation (ESXi)4.xAlgunaCVE-2020-40058.8Importante 4.1.0.1NingunaNinguna
VMware Cloud Foundation (ESXi)3.xAlgunaCVE-2020-40058.8Importante 3.10.1.2NingunaNinguna

4. Referencias


Descargas y documentación de VMware ESXi 7.0 ESXi70U1b-17168206 :
https://my.vmware.com/group/vmware/patch
https://docs.vmware.com/en/VMware-vSphere/7.0/rn/vsphere-esxi-70u1b .html


Descargas y documentación de VMware ESXi 6.7 ESXi670-202011101-SG :
https://my.vmware.com/group/vmware/patch
https://docs.vmware.com/en/VMware-vSphere/6.7/rn/esxi670-202011002.html


Descargas y documentación de VMware ESXi 6.5 ESXi650-202011301-SG :
https://my.vmware.com/group/vmware/patch
https://docs.vmware.com/en/VMware-vSphere/6.5/rn/esxi650-202011002.html


Descargas y documentación de VMware Workstation Pro 15.5.7 :
https://www.vmware.com/go/downloadworkstation
https://docs.vmware.com/en/VMware-Workstation-Pro/index.html


Descargas y documentación de VMware Workstation Player 15.5.7 :
https://www.vmware.com/go/downloadplayer
https://docs.vmware.com/en/VMware-Workstation-Player/index.html


Descargas y documentación de VMware Fusion 11.5.7 :
https://www.vmware.com/go/downloadfusion
https://docs.vmware.com/en/VMware-Fusion/index.html

VMware vCloud Foundation 4.1.0.1
https://docs.vmware.com/en/VMware-Cloud-Foundation/4.1/rn/VMware-Cloud-Foundation-41-Release-Notes.html#4.1.0.1

VMware vCloud Foundation 3.10.1.2
https://docs.vmware.com/en/VMware-Cloud-Foundation/3.10.1/rn/VMware-Cloud-Foundation-3101-Release-Notes.html#3.10.1.2

Enlaces del diccionario Mitre CVE:
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-4004
https://cve.mitre.org/cgi-bin/cvename.cgi?name= CVE-2020-4005

PRIMERA calculadora CVSSv3: CVE-2020-4004 – https://www.first.org/cvss/calculator/3.1#CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/ C: H / I: H / A: H CVE-2020-4005 – https://www.first.org/cvss/calculator/3.1#CVSS:3.1/AV:L/AC:L/PR:L/UI : N / S: C / C: H / I: H / A: H

VMSA-2020-0027.1

2020-11-23

1. Productos afectados
  • VMware Workspace One Access (acceso)
  • Conector de acceso de VMware Workspace One (conector de acceso)
  • Administrador de identidades de VMware (vIDM)
  • Conector de VMware Identity Manager (conector vIDM)
  • Fundación VMware Cloud
  • vRealize Suite Lifecycle Manager
2. Introducción

Se informó de forma privada a VMware sobre una vulnerabilidad de inyección de comandos. Hay soluciones alternativas disponibles para abordar esta vulnerabilidad en los productos VMware afectados.

3a. Vulnerabilidad de inyección de comandos en el configurador administrativo de VMware Workspace One Access, Access Connector, Identity Manager e Identity Manager Connector (CVE-2020-4006)

Descripción

VMware Workspace One Access, Access Connector, Identity Manager e Identity Manager Connector contienen una vulnerabilidad de inyección de comandos en el configurador administrativo. VMware ha evaluado que este problema es de gravedad crítica con una puntuación base máxima de CVSSv3 de 9.1.

Vectores de ataque conocidos

Un actor malintencionado con acceso de red al configurador administrativo en el puerto 8443 y una contraseña válida para la cuenta de administrador del configurador puede ejecutar comandos con privilegios no restringidos en el sistema operativo subyacente.

Resolución

Próximamente se publicarán parches para CVE-2020-4006. Consulte ‘Soluciones provisionales’ a continuación para obtener una solución temporal para evitar la explotación de CVE-2020-4006.

Soluciones alternativas

Las soluciones provisionales para CVE-2020-4006 se enumeran en la columna ‘Soluciones provisionales’ de la ‘Matriz de respuesta’ a continuación.

Notas

[1] Estos conjuntos de productos implementan los componentes afectados que se enumeran en la tabla 3a. Las soluciones alternativas de KB81731 deben aplicarse directamente a los componentes afectados que estos conjuntos de productos han implementado siguiendo las mismas instrucciones.

Matriz de respuesta 3a:

ProductoVersiónQue se ejecuta enIdentificador CVECVSSv3GravedadVersión fijaSoluciones alternativasDocumentación adicional
Acceso20.10LinuxCVE-2020-40069.1Crítico Parche pendienteKB81731Ninguna
Acceso20.10VentanasCVE-2020-4006N / AN / AInafectadoN / AN / A
Acceso20.01LinuxCVE-2020-40069.1Crítico Parche pendienteKB81731Ninguna
Acceso20.01VentanasCVE-2020-4006N / AN / AInafectadoN / AN / A
Conector de acceso20.10, 20.01.0.0, 20.01.0.1VentanasCVE-2020-4006N / AN / AInafectadoN / AN / A
vIDM3.3.3LinuxCVE-2020-40069.1Crítico Parche pendienteKB81731Ninguna
vIDM3.3.3VentanasCVE-2020-4006N / AN / AInafectadoN / AN / A
vIDM3.3.2LinuxCVE-2020-40069.1Crítico Parche pendienteKB81731Ninguna
vIDM3.3.2VentanasCVE-2020-4006N / AN / AInafectadoN / AN / A
vIDM3.3.1LinuxCVE-2020-40069.1Crítico Parche pendienteKB81731Ninguna
vIDM3.3.1VentanasCVE-2020-4006N / AN / AInafectadoN / AN / A
Conector vIDM19.03.0.0, 19.03.0.1VentanasCVE-2020-4006N / AN / AInafectadoN / AN / A
Conector vIDM3.3.3VentanasCVE-2020-40069.1Crítico Parche pendienteKB81731Ninguna
Conector vIDM3.3.2LinuxCVE-2020-40069.1Crítico Parche pendienteKB81731Ninguna
Conector vIDM3.3.2VentanasCVE-2020-40069.1Crítico Parche pendienteKB81731Ninguna
Conector vIDM3.3.1LinuxCVE-2020-40069.1Crítico Parche pendienteKB81731Ninguna
Conector vIDM3.3.1VentanasCVE-2020-40069.1Crítico Parche pendienteKB81731Ninguna

Conjuntos de productos afectados que implementan componentes de Response Matrix 3a:

ProductoVersiónQue se ejecuta enIdentificador CVECVSSv3GravedadVersión fijaSoluciones alternativasDocumentación adicional
[1] VMware Cloud Foundation (vIDM)4.xAlgunaCVE-2020-40069.1Crítico Parche pendienteKB81731Ninguna
[1] vRealize Suite Lifecycle Manager (vIDM)8.xAlgunaCVE-2020-40069.1Crítico Parche pendienteKB81731Ninguna
4. Referencias

Soluciones alternativas:
https://kb.vmware.com/s/article/81731

Enlaces del diccionario Mitre CVE:
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-4006

PRIMERA calculadora CVSSv3:
CVE-2020-4006 – https://www.first.org/cvss/calculator/3.0#CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/ C: H / I: H / A: H

Fuente: VMware

Alguna duda o información que necesites sobre este tema, contáctanos por cualquiera de nuestro medios disponibles. ¡Estaremos encantados de ayudarte!