fbpx

VMware Security Advisories – Noviembre 2019

VMware Security Advisories – Noviembre 2019

VMSA-2019-0020

VMware ESXi, Workstation, and Fusion patches provide Hypervisor-Specific Mitigations for Speculative-Execution Vulnerabilities (CVE-2018-12207, CVE-2019-11135)

1. Productos impactados
  • VMware ESXi
  • VMware Estación de trabajo
  • VMware Fusion
2. Introducción

Se han detectado vulnerabilidades que afectan a los procesadores Intel:

  • CVE-2018-12207: error de verificación de la máquina al cambiar el tamaño de página (MCEPSC)
  • CVE-2019-11135 – Aborto asíncrono TSX (TAA)

Existen parches del Hypervisor VMware disponibles que brindan opciones de mitigación tanto para CVE-2018-12207 como para CVE-2019-11135.

3a. Mitigaciones específicas de hipervisor para el error de verificación de la máquina al cambiar el tamaño de pagina (MCEPSC). Vulnerabilidad de denegación de servicio (CVE-2018-12207).

Descripción:

Los parches para VMware ESXi, Workstation y Fusion incluyen mitigaciones específicas del hipervisor para el error de verificación de la máquina en el cambio de tamaño de página (MCEPSC). VMware ha evaluado que este problema se encuentra en el rango de gravedad Moderado.

Vectores de ataque conocidos:

Un actor malicioso con acceso local para ejecutar código en una máquina virtual, puede activar una pantalla de diagnóstico púrpura o un reinicio inmediato del hipervisor que aloja la máquina virtual, lo que resulta en una condición de denegación de servicio.

Resolución:

Para mitigar CVE-2018-12207, consulte la ‘Matriz de respuesta’ a continuación. Primero aplique todos los parches enumerados en la columna ‘Versión fija’ y luego siga las instrucciones que se encuentran en el artículo de KB en la columna ‘documentación adicional’ para su producto respectivo.

Soluciones alternativas:

Ninguna.

Documentación adicional:

Debido a que las mitigaciones para CVE-2018-12207 pueden tener un impacto en el rendimiento, no están habilitadas de forma predeterminada. Después de aplicar todos los parches de la columna ‘Versión fija’ a continuación, se puede habilitar la mitigación siguiendo las instrucciones que se encuentran en el artículo de KB en la columna ‘Documentación adicional’ para el producto. Los datos de impacto en el rendimiento encontrados en el KB76050 deben revisarse antes de habilitar esta mitigación.

Matriz de respuesta:

3b. Mitigaciones específicas del hipervisor para la vulnerabilidad de ejecución especulativa de aborto asincrónico (TAA) de TSX (CVE-2019-11135)

Descripción:

Los parches VMware ESXi, Workstation y Fusion incluyen mitigaciones específicas de hipervisor para TSX Asynchronous Abort (TAA). VMware ha evaluado que este problema se encuentra en el rango de gravedad Moderado.

Vectores de ataque conocidos:

Un actor malicioso con acceso local para ejecutar código en una máquina virtual puede inferir datos protegidos de otra manera por mecanismos arquitectónicos desde otra máquina virtual o el propio hipervisor. Esta vulnerabilidad solo es aplicable a los hipervisores que utilizan microarquitectura de procesadores escalables Intel® Xeon® de segunda generación (anteriormente conocido como Cascade Lake).

Resolución:

Para mitigar CVE-2019-11135, aplique todos los parches enumerados en la columna ‘Versión fija’ que se encuentra en la ‘Matriz de respuestas’ a continuación.

Soluciones alternativas:

Ninguna.

Matriz de respuesta:

4. Referencias

Versión (es) y notas de lanzamiento:

ESXi 6.7Versión del parche ESXi670-201911001
https://my.vmware.com/group/vmware/patch
https://docs.vmware.com/en/VMware-vSphere/6.7/rn/esxi670-201911001.html

ESXi 6.5Versión del parche ESXi650-201911001
https://my.vmware.com/group/vmware/patch
https://docs.vmware.com/en/VMware-vSphere/6.5/rn/esxi650-201911001.html

ESXi 6.0Versión del parche ESXi600-201911001
https://my.vmware.com/group/vmware/patch
https://docs.vmware.com/en/VMware-vSphere/6.0/rn/esxi600-201911001.html

VMware Workstation 15.5.1
https://www.vmware.com/go/downloadworkstation
https://docs.vmware.com/en/VMware-Workstation-Pro/index.html

VMware Fusion 11.5.1
https://www.vmware.com/go/downloadfusion
https://docs.vmware.com/en/VMware-Fusion/index.html

Documentación adicional:

https://kb.vmware.com/s/article/59139

VMSA-2019-0021

VMware Workstation and Fusion updates address multiple security vulnerabilities (CVE-2019-5540, CVE-2019-5541, CVE-2019-5542)

1. Productos impactados
  • VMware Workstation Pro / Player (estación de trabajo)
  • VMware Fusion Pro / Fusion (Fusion)
2. Introducción

VMware Workstation y Fusion contienen múltiples vulnerabilidades de seguridad. Hay parches y soluciones disponibles para remediar estas vulnerabilidades en los productos VMware afectados.

3a. Vulnerabilidad de escritura fuera de límites de VMware Workstation y Fusion en el adaptador de red virtual e1000e (CVE-2019-5541)

Descripción:

VMware Workstation y Fusion contienen una vulnerabilidad de escritura fuera de los límites en el adaptador de red virtual e1000e. VMware ha evaluado la gravedad de este problema para estar en el rango de severidad importante.

Vectores de ataque conocidos:

La explotación exitosa de este problema puede conducir a la ejecución de código en el host del huésped o puede permitir a los atacantes crear una condición de denegación de servicio en su propia VM.

Resolución:

Para remediar CVE-2019-5541, aplique los parches enumerados en la columna ‘Versión fija’ de la ‘Matriz de resolución’ que se encuentra a continuación.

Soluciones alternativas:

Ninguna.

Matriz de resolución:

3c. Vulnerabilidad de denegación de servicio de VMware Workstation y Fusion (CVE-2019-5542)

Descripción:

VMware Workstation y Fusion contienen una vulnerabilidad de denegación de servicio en el controlador RPC. VMware ha evaluado la gravedad de este problema para estar en el rango de gravedad moderada.

Vectores de ataque conocidos:

La explotación exitosa de este problema puede permitir a los atacantes con privilegios normales de usuario crear una condición de denegación de servicio en su propia VM.

Resolución:

Para remediar CVE-2019-5542, aplique los parches enumerados en la columna ‘Versión fija’ de la ‘Matriz de resolución’ que se encuentra a continuación.

Soluciones alternativas:

Ninguna.

Matriz de resolución:

4. Referencias

Versión (es) fija (s) y notas de lanzamiento:

VMware Workstation Pro 15.5.1

Descargas y documentación:

https://www.vmware.com/go/downloadworkstation

https://docs.vmware.com/en/VMware-Workstation-Pro/index.html

VMware Workstation Player 15.5.1

Descargas y documentación:

https://www.vmware.com/go/downloadplayerhttps://docs.vmware.com/en/VMware-Workstation-Player/index.html

VMware Fusion 11.5.1
Descargas y documentación:
https://www.vmware.com/go/downloadfusion
https://docs.vmware.com/en/VMware-Fusion/index.html

Enlaces del Diccionario Mitre CVE:
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-5540
https://cve.mitre.org/cgi-bin/cvename.cgi?name= CVE-2019-5541
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-5542

Fuente: VMware

 

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *